Elxis CMS Forum

Community => Elxis Community => Topic started by: speck on October 12, 2010, 12:06:09

Title: translation need for a new plug-in and module
Post by: speck on October 12, 2010, 12:06:09
can you translate? are two short files, one for a plug in and other for a module
thanks a lot.


[attachment deleted by admin]
Title: Re: translation need for a new plug-in and module
Post by: yiannisK on October 12, 2010, 17:13:18
Greek

[attachment deleted by admin]
Title: Re: translation need for a new plug-in and module
Post by: cfb1972 on October 12, 2010, 18:57:43
I can do Romanian...
Title: Re: translation need for a new plug-in and module
Post by: datahell on October 12, 2010, 19:03:54
yiannisK you were really fast! :D
Title: Re: translation need for a new plug-in and module
Post by: speck on October 12, 2010, 19:07:07
I can do Romanian...
Of course...
for me are two useful extensions, i hope will be for elxis users too ;)

in the meantime thanks a lot Yiannisk  ;)

don't worry ioannis...
if you want i send to you the php files  ;D
Title: Re: translation need for a new plug-in and module
Post by: yiannisK on October 13, 2010, 03:26:11
10 lines translation... yes really fast  :P
Title: Re: translation need for a new plug-in and module
Post by: Amigamerlin on October 13, 2010, 09:56:41
Ciao Speck
I can do Italian translation but I can guess you don't need it  ;D.

I'm Right?

Ciao  ;)
Title: Re: translation need for a new plug-in and module
Post by: Ivan TrebjeŇ°anin on October 13, 2010, 11:11:00
Serbian cyrillic and latin version  :)

[attachment deleted by admin]
Title: Re: translation need for a new plug-in and module
Post by: cfb1972 on October 13, 2010, 12:31:08
Romanian version. Please check encoding as I've used Notepad (not at my PC, sorry).


[attachment deleted by admin]
Title: Re: translation need for a new plug-in and module
Post by: speck on October 13, 2010, 21:42:11
thanks at all, you're always great
the module and plug-inTABS / SLIDES are in EDC. :)
Title: Re: translation need for a new plug-in and module
Post by: webgift on October 15, 2010, 13:13:18
Thanks a lot WebGift for your little adjustment. I upgraded the new version.
Now I understand, but overall learned a thing in more.  :)
Title: Re: translation need for a new plug-in and module
Post by: speck on October 15, 2010, 19:30:21
OPS
I've modified your topics  ;D sorry

Thanks a lot WebGift for your little adjustment. I upgraded the new version.
Now I understand, but overall learned a thing in more.

Title: Re: translation need for a new plug-in and module
Post by: datahell on October 15, 2010, 20:33:29
Speck I changed the word "plug-in" with the word "bot" in your listing in EDC.
Elxis does not have "plug-ins" it has "bots".

Thanks for the extensions!
Title: Re: translation need for a new plug-in and module
Post by: webgift on October 16, 2010, 12:24:13
Bravo Speck.
Notice what Datahell have told you about names that Elxis Community use.;)

Keep Going ...
Title: Re: translation need for a new plug-in and module
Post by: webgift on November 04, 2010, 18:10:40
Speck i test the Tabs / Slides Bot (http://www.elxis-downloads.com/downloads/sliders-scrollers-tabs/282.html) and i found a serious issue.
On one autonomous page i have used that bot.
For all other autonomous pages of the site ,  the html extract this piece of code that it's not needed :

------------------------
<style type="text/css" media="screen">
      @import "http://www.domainame.com/mambots/content/tabs_slides/tabs_slides.css";
      </style>

      <style type="text/css" media="print">.jwts_tabbernav{display:none;}</style>
      <script type="text/javascript">var jwts_slideSpeed="2"; var jwts_timer="2";</script>
      <script type="text/javascript" src="http://www.domainname.com/mambots/content/tabs_slides/tabs_slides_comp.js">
</script><script type="text/javascript" src="http://www.domainame.com/mambots/content/tabs_slides/tabs_slides_def_loader.js"></script>
----------------------

take a look of that.
Title: Re: translation need for a new plug-in and module
Post by: speck on November 04, 2010, 18:42:13
 :o
ive tried now in local and on the server under elxis 2009.2
the sane under 2009.1 was
all works right

i sent to you now a PM with two links...

are you using the module too on the same site???
Title: Re: translation need for a new plug-in and module
Post by: webgift on November 04, 2010, 19:57:38
It doesn't change.!

I have two autonomous pages on one website.
At the first autonomous page run eforms bot and at the second one the Tabs / Slides Bot.

When i see the autonomous page about eforms bot the html code of that page extracts beside of the lines of eforms the code :

<style type="text/css" media="screen">@import "http://www.domainame.com/mambots/content/tabs_slides/tabs_slides.css"</style><style type="text/css" media="print">jwts_tabbernav{display:none;}</style><script type="text/javascript">var jwts_slideSpeed="2"; var jwts_timer="2"</script><script type="text/javascript" src="http://www.domainame.com/mambots/content/tabs_slides/tabs_slides_comp.js"></script><script type="text/javascript" src="http://www.domainame.com/mambots/content/tabs_slides/tabs_slides_def_loader.js"></script>
<link href="http://www.domainame.com/mambots/content/eforms/eforms.css" rel="stylesheet" type="text/css" media="all" />
Title: Re: translation need for a new plug-in and module
Post by: speck on November 04, 2010, 21:30:30
i've tried with eform installed ... to me works right.
in any case i rewrited now some code and i sent it to you the new version by mail.
advise me if is all ok or not  :)
have a good evening  :)
Title: Re: translation need for a new plug-in and module
Post by: webgift on November 05, 2010, 08:46:02
Now we are ok!
As you send me the issue was at line 96

if ((preg_match_all('/{tab=.+?}{tab=.+?}|{tab=.+?}|{\/tabs}/', $row->text, $matches, PREG_PATTERN_ORDER) > 0) || (preg_match_all('/{slide=.+?}/', $row->text, $matches, PREG_PATTERN_ORDER) > 0)) {    

at version 1.0 there wasn't that line ;).
Title: Re: translation need for a new plug-in and module
Post by: speck on November 05, 2010, 10:07:10
Thanks dear friend
I updated it on EDC with new version  :)